Timingprobleme? (MIDI / Audio)


DjKeeper
DjKeeper
Well-known member
Mitglied seit
12 Aug 2001
Beiträge
774
Reaktionen
73
Ort
Schleswig Holstein
moin.

ich habe folgendes problem: ich kann softwaresynthesizer und hardwaresynths super parallel betreiben, sprich: die midi-ausgabe wird von meinem sequenzer automatisch um die latenz verspätet.
aber wenn ich nun meine hardware synths aufnehmen will stimmt gar nix mehr, die aufnahme ist nicht mehr synchron, und ich muss sie per delay von hand wieder in phase bringen.

woran liegt das? ist es das was man als samplegenaues midi-timig bezeichnet? kann es sein das meine soundkarte probleme bereitet, die aufnahme auf irgendeine weise MIDI-synchron zu halten?

gruß,
vielen dank im voraus

PS.: war lange nicht mehr hier, sieht gut aus, das neue layout ;)
 
S
SChrauber
Selbsternannte Forenhecht
Mitglied seit
4 Jul 2002
Beiträge
1.426
Reaktionen
207
Ort
Hinter den Bergen
Ehrlich gesagt. Mich verwirrt das ganze grad ein bisschen.
Eigentlich müsste es doch so sein:
Im Normalfall: Ich drücke auf Play und die Maschinen fangen an laufen. Wenn nun plötzlich zu wenig Prozessorleistung vorhanden ist kommt es zu Aussetzern, bzw. Knacksen.
Man muss also den Software-Maschinen mehr Rechenzeit zur Verfügung stellen.
Es wird eine Latenz eingestellt, und die Maschinen laufen eben nicht augenblicklich nach dem Drücken von Start los sondern verzögert – Es ist dadurch mehr Prozessorkapazität (Zeit) vorhanden.
Bei nicht Real-Time relevanten Material, sprich abspielen der Aufnahme dürfte dies kein Problem sein.
Also ist doch anzunehmen, dass in diesem Falle die Aufnahme direkt in Real-Time beginnt, wärend die gesamte Software noch mit Latenz später abgespielt wird. Bedeutet in der Praxis also: Ich höre z.B. eine Basedrum von einer Software – Natürlich höre ich diese mit der eingestellten Latenz. Spiele ich nun Real-Time darauf eine Hihat, so hab ich diese eigentlich zu Spät eingespielt, da ich ja nach Latenz-Zeitreferenz eingespielt habe.
Aber eigentlich dürfte das doch nun nicht sein, oder benötigt man tatsächlich Zero-Latenz für Aufnahme zu Software-Playback?
Erinnere mich an alte HD-Recording-Systeme, die bei vielen Spuren eben schon recht lange brauchten um loszulaufen – Da hats dann eben auch mal ne Sekunde gedauert bis die Aufnahme begann, nach drücken von Rec – aber es war dann auf jeden Fall in Time
 
DjKeeper
DjKeeper
Well-known member
Mitglied seit
12 Aug 2001
Beiträge
774
Reaktionen
73
Ort
Schleswig Holstein
Original geschrieben von SChrauber
Aber eigentlich dürfte das doch nun nicht sein, oder benötigt man tatsächlich Zero-Latenz für Aufnahme zu Software-Playback?

na das is es ja, eben nicht! (das wäre ja... )
es wurde ja für die RME hammerfalls damit werbung gemacht, das "audio und midi aneinander kleben", also hammer-synchron sind, was zu dem zeitpunkt keine selbstverständlichkeit gewesen zu sein scheint. ich weis absolut nicht, was die damit genau meinten, ich frage mich desshalb, ob die verzögerung wirklich an der einganslatenz liegt (welche mit sicherheit von logic automatisch ausgeglichen wird, zumal ich einen gitarristen zu einem bereits vorhandenen gitarrentake jederzeit nochmal was einspielen lassen kann was dann definitiv synchron ist) oder ob meine soundkarte und das midiinterface einfach so schlecht parallel coordiniert werden können, das alles durcheinander kommt. (und ich mir eine karte kaufen sollte wo alles aneinander klebt.)

danke für die bisherigen antworten
greetz
 
DjKeeper
DjKeeper
Well-known member
Mitglied seit
12 Aug 2001
Beiträge
774
Reaktionen
73
Ort
Schleswig Holstein
problem gelöst.

das handbuch konnte mir nicht helfen, da es dort haupsächlich um die synchronisation mit bandmaschinen & co geht.

also habe ich da angerufen, und tatsächlich: der total veraltete asio2 treiber meiner karte ist nur für cubase konzipiert, was bewirkt das die aktuelle latenz nicht richtig zurückgemeldet wird was es für logic wiederum unmöglich macht diese zu kompensieren.

das ganze hat also mit midi-synchronisation nix zu tun.
was RME mit dem "midi und audio kleben zusammen" meinte weiß ich jetz auch, hat nix mit sequenzing zu tun.

anstatt mir schon wieder ne neue karte zu holen muss ich in logic nur für jede spur einen negativen delay von 164 einstellen, dann klappt alles.

greetz
 
Badtrans
Badtrans
N00b
Mitglied seit
13 Jan 2002
Beiträge
2.330
Reaktionen
28
Ort
Haiger
hmm... *thread rauskram* muss mir in diesem Zusammenhang auch was überlegen ;)

Irgendwie bewirkt @DJKeeper Deine Methode ja eine "negative Verzögerung" des Midisignals und gleichzeitig eine positive Verzögerung des Audiomaterials, also quasi eine Verschiebung der Midi-Noten nach vorne/links/Vergangenheit, was sich dadurch bemerkbar macht, dass die Note(n), die durch diese Art beim Starten eines Bereichs vor dem Cursor/Startmarker landen, verschluckt werden. Nunja, kann man bei der Aufnahme alles noch umgehen, aber trotzdem nervt dieses Latenzgegurke.

*denk* irgendwo konnte man das auch global einstellen.
Nunja, bei mir liegt der optimale Wert bei ca. -44 und Fehler in diesem Bereich, sofern nicht gerade Perkussives Material aufgenommen wird, können vom Ohr noch als Groove interpretiert werden.
 
 

Neue Themen


Oben